RHEL 5 : icu (RHSA-2008:0090)

This script is Copyright (C) 2008-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated icu packages that fix two security issues are now available
for Red Hat Enterprise Linux 5.

This update has been rated as having important security impact by the
Red Hat Security Response Team.

The International Components for Unicode (ICU) library provides robust
and full-featured Unicode services.

Will Drewry reported multiple flaws in the way libicu processed
certain malformed regular expressions. If an application linked
against ICU, such as OpenOffice.org, processed a carefully crafted
regular expression, it may be possible to execute arbitrary code as
the user running the application. (CVE-2007-4770, CVE-2007-4771)

All users of icu should upgrade to these updated packages, which
contain backported patches to resolve these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2007-4770.html
https://www.redhat.com/security/data/cve/CVE-2007-4771.html
http://rhn.redhat.com/errata/RHSA-2008-0090.html

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 30091 ()

Bugtraq ID:

CVE ID: CVE-2007-4770
CVE-2007-4771