Ubuntu 6.06 LTS : xorg-server vulnerability (USN-514-1)

Ubuntu Security Notice (C) 2007-2015 Canonical, Inc. / NASL script (C) 2007-2015 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Aaron Plattner discovered that the Composite extension did not
correctly calculate the size of buffers when copying between different
bit depths. An authenticated user could exploit this to execute
arbitrary code with root privileges.

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:L/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 28119 ()

Bugtraq ID: 25606

CVE ID: CVE-2007-4730