Ubuntu 6.06 LTS / 6.10 / 7.04 : quagga vulnerability (USN-512-1)

Ubuntu Security Notice (C) 2007-2013 Canonical, Inc. / NASL script (C) 2007-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that Quagga did not correctly verify OPEN messages
or COMMUNITY attributes sent from configured peers. Malicious
authenticated remote peers could send a specially crafted message
which would cause bgpd to abort, leading to a denial of service.

Solution :

Update the affected quagga and / or quagga-doc packages.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 28117 ()

Bugtraq ID: 25634

CVE ID: CVE-2007-4826