Ubuntu 6.06 LTS / 6.10 / 7.04 : krb5, librpcsecgss vulnerability (USN-511-2)

Ubuntu Security Notice (C) 2007-2013 Canonical, Inc. / NASL script (C) 2007-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

USN-511-1 fixed vulnerabilities in krb5 and librpcsecgss. The fixes
were incomplete, and only reduced the scope of the vulnerability,
without fully solving it. This update fixes the problem.

It was discovered that the libraries handling RPCSEC_GSS did not
correctly validate the size of certain packet structures. An
unauthenticated remote user could send a specially crafted request and
execute arbitrary code with root privileges.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 28116 ()

Bugtraq ID:

CVE ID: CVE-2007-4743