Ubuntu 5.10 / 6.06 LTS / 6.10 : openldap2.2 vulnerability (USN-384-1)

Ubuntu Security Notice (C) 2006-2013 Canonical, Inc. / NASL script (C) 2007-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Evgeny Legerov discovered that the OpenLDAP libraries did not
correctly truncate authcid names. This situation would trigger an
assert and abort the program using the libraries. A remote attacker
could send specially crafted bind requests that would lead to an LDAP
server denial of service.

Solution :

Update the affected ldap-utils, libldap-2.2-7 and / or slapd packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 27967 ()

Bugtraq ID:

CVE ID: CVE-2006-5779