Ubuntu 5.04 / 5.10 / 6.06 LTS : qt-x11-free vulnerability (USN-368-1)

Ubuntu Security Notice (C) 2006-2015 Canonical, Inc. / NASL script (C) 2007-2015 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

An integer overflow was discovered in Qt's image loader. By processing
a specially crafted image with an application that uses this library
(like Konqueror), a remote attacker could exploit this to execute
arbitrary code with the application's privileges.

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 27948 ()

Bugtraq ID: 20599

CVE ID: CVE-2006-4811