GLSA-200711-13 : 3proxy: Denial of Service

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200711-13
(3proxy: Denial of Service)

3proxy contains a double free vulnerability in the ftpprchild()
function, which frees param->hostname and calls the parsehostname()
function, which in turn attempts to free param->hostname again.

Impact :

A remote attacker could send a specially crafted request to the proxy,
possibly resulting in a Denial of Service. Under typical configuration,
the scope of this vulnerability is limited to the local network.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All 3proxy users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-proxy/3proxy-0.5.3j'

Risk factor :

Medium / CVSS Base Score : 5.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 27848 (gentoo_GLSA-200711-13.nasl)

Bugtraq ID:

CVE ID: CVE-2007-5622