GLSA-200710-15 : KDM: Local privilege escalation

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200710-15
(KDM: Local privilege escalation)

Kees Huijgen discovered an error when checking the credentials which
can lead to a login without specifying a password. This only occurs
when auto login is configured for at least one user and a password is
required to shut down the machine.

Impact :

A local attacker could gain root privileges and execute arbitrary
commands by logging in as root without specifying root's password.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200710-15.xml

Solution :

All KDM users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=kde-base/kdm-3.5.7-r2'
All kdebase users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=kde-base/kdebase-3.5.7-r4'

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 27050 (gentoo_GLSA-200710-15.nasl)

Bugtraq ID:

CVE ID: CVE-2007-4569