GLSA-200708-03 : libarchive (formerly named as bsdtar): Multiple PaX Extension Header Vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200708-03
(libarchive (formerly named as bsdtar): Multiple PaX Extension Header Vulnerabilities)

CPNI, CERT-FI, Tim Kientzle, and Colin Percival reported a buffer
overflow (CVE-2007-3641), an infinite loop (CVE-2007-3644), and a NULL
pointer dereference (CVE-2007-3645) within the processing of archives
having corrupted PaX extension headers.

Impact :

An attacker can trick a user or automated system to process an archive
with malformed PaX extension headers into execute arbitrary code, crash
an application using the library, or cause a high CPU load.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200708-03.xml

Solution :

All libarchive or bsdtar users should upgrade to the latest libarchive
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-arch/libarchive-2.2.4'

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25868 (gentoo_GLSA-200708-03.nasl)

Bugtraq ID:

CVE ID: CVE-2007-3641
CVE-2007-3644
CVE-2007-3645