GLSA-200707-05 : Webmin, Usermin: Cross-site scripting vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200707-05
(Webmin, Usermin: Cross-site scripting vulnerabilities)

The pam_login.cgi file does not properly sanitize user input before
sending it back as output to the user.

Impact :

An unauthenticated attacker could entice a user to browse a specially
crafted URL, allowing for the execution of script code in the context
of the user's browser and for the theft of browser credentials. This
may permit the attacker to login to Webmin or Usermin with the user's
permissions.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200707-05.xml

Solution :

All Webmin users should update to the latest stable version:
# emerge --sync
# emerge --ask --verbose --oneshot '>=app-admin/webmin-1.350'
All Usermin users should update to the latest stable version:
# emerge --sync
# emerge --ask --verbose --oneshot '>=app-admin/usermin-1.280'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25680 (gentoo_GLSA-200707-05.nasl)

Bugtraq ID:

CVE ID: CVE-2007-3156