GLSA-200705-23 : Sun JDK/JRE: Multiple vulnerabilities

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200705-23
(Sun JDK/JRE: Multiple vulnerabilities)

An unspecified vulnerability involving an 'incorrect use of system
classes' was reported by the Fujitsu security team. Additionally, Chris
Evans from the Google Security Team reported an integer overflow
resulting in a buffer overflow in the ICC parser used with JPG or BMP
files, and an incorrect open() call to /dev/tty when processing certain
BMP files.

Impact :

A remote attacker could entice a user to run a specially crafted Java
class or applet that will trigger one of the vulnerabilities. This
could lead to the execution of arbitrary code outside of the Java
sandbox and of the Java security restrictions, or crash the Java
application or the browser.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200705-23.xml

Solution :

All Sun Java Development Kit users should upgrade to the latest
version:
# emerge --sync
# emerge --ask --oneshot --verbose 'dev-java/sun-jdk'
All Sun Java Runtime Environment users should upgrade to the latest
version:
# emerge --sync
# emerge --ask --oneshot --verbose 'dev-java/sun-jre-bin'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 25382 (gentoo_GLSA-200705-23.nasl)

Bugtraq ID:

CVE ID: CVE-2007-2435
CVE-2007-2788
CVE-2007-2789