RHEL 3 / 4 / 5 : vixie-cron (RHSA-2007:0345)

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

Updated vixie-cron packages that fix a denial of service issue are now
available.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

The vixie-cron package contains the Vixie version of cron. Cron is a
standard UNIX daemon that runs specified programs at scheduled times.

Raphael Marichez discovered a denial of service bug in the way
vixie-cron verifies crontab file integrity. A local user with the
ability to create a hardlink to /etc/crontab can prevent vixie-cron
from executing certain system cron jobs. (CVE-2007-1856)

All users of vixie-cron should upgrade to these updated packages,
which contain a backported patch to correct this issue.

See also :

https://www.redhat.com/security/data/cve/CVE-2007-1856.html
http://rhn.redhat.com/errata/RHSA-2007-0345.html

Solution :

Update the affected vixie-cron package.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 25267 ()

Bugtraq ID:

CVE ID: CVE-2007-1856