GLSA-200703-28 : CUPS: Denial of Service

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200703-28
(CUPS: Denial of Service)

CUPS does not properly handle partially-negotiated SSL connections.
Upon receiving a partially-negotiated SSL connection, CUPS no longer
accepts further incoming connections, as the initial connection never
times out.

Impact :

An attacker could partially negotiate an SSL connection with a CUPS
server, and cause future connections to that server to fail, resulting
in a Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200703-28.xml

Solution :

All CUPS users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-print/cups-1.2.9'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24933 (gentoo_GLSA-200703-28.nasl)

Bugtraq ID:

CVE ID: CVE-2007-0720