GLSA-200703-24 : mgv: Stack overflow in included gv code

This script is Copyright (C) 2007-2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200703-24
(mgv: Stack overflow in included gv code)

mgv includes code from gv that does not properly boundary check
user-supplied data before copying it into process buffers.

Impact :

An attacker could entice a user to open a specially crafted Postscript
document with mgv and possibly execute arbitrary code with the rights
of the user running mgv.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200611-20.xml
https://security.gentoo.org/glsa/200703-24

Solution :

mgv is currently unmaintained, and the mgv website no longer exists. As
such, the mgv package has been masked in Portage. We recommend that
users select an alternate Postscript viewer such as ghostview or
GSview, and unmerge mgv:
# emerge --unmerge 'app-text/mgv'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.4
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24929 (gentoo_GLSA-200703-24.nasl)

Bugtraq ID: 20978

CVE ID: CVE-2006-5864