GLSA-200703-17 : ulogd: Remote execution of arbitrary code

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200703-17
(ulogd: Remote execution of arbitrary code)

SUSE reported unspecified buffer overflows in ulogd involving the
calculation of string lengths.

Impact :

A remote attacker could trigger a possible buffer overflow through
unspecified vectors, potentially leading to the remote execution of
arbitrary code with the rights of the user running the ulogd daemon, or
more probably leading to the crash of the daemon.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200703-17.xml

Solution :

All ulogd users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-admin/ulogd-1.23-r1'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24866 (gentoo_GLSA-200703-17.nasl)

Bugtraq ID:

CVE ID: CVE-2007-0460