GLSA-200703-06 : AMD64 x86 emulation Qt library: Integer overflow

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200703-06
(AMD64 x86 emulation Qt library: Integer overflow)

An integer overflow flaw has been found in the pixmap handling of Qt,
making the AMD64 x86 emulation Qt library vulnerable as well.

Impact :

By enticing a user to open a specially crafted pixmap image in an
application using the AMD64 x86 emulation Qt library, a remote attacker
could cause an application crash or the remote execution of arbitrary
code with the rights of the user running the application.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200611-02.xml
http://www.gentoo.org/security/en/glsa/glsa-200703-06.xml

Solution :

All AMD64 x86 emulation Qt library users should upgrade to the latest
version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-emulation/emul-linux-x86-qtlibs-10.0'

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24773 (gentoo_GLSA-200703-06.nasl)

Bugtraq ID:

CVE ID: CVE-2006-4811