Quicktime < 7.1.5 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2007-2011 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains an application that is prone to
multiple attacks.

Description :

According to its version, the installation of Quicktime on the remote
Mac OS X host is affected by multiple buffer overflows. An attacker
may be able to leverage these issues to crash the affected application
or to execute arbitrary code on the remote host by sending a
specially crafted file to a victim and having him open it using
QuickTime.

See also :

http://docs.info.apple.com/article.html?artnum=305149

Solution :

Upgrade to Quicktime version 7.1.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 24762 (macosx_Quicktime715.nasl)

Bugtraq ID: 22827

CVE ID: CVE-2007-0712
CVE-2007-0713
CVE-2007-0714
CVE-2007-0715
CVE-2007-0716
CVE-2007-0717
CVE-2007-0718