GLSA-200702-05 : Fail2ban: Denial of Service

This script is Copyright (C) 2007-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200702-05
(Fail2ban: Denial of Service)

A flaw in the method used to parse log entries allows remote,
unauthenticated attackers to forge authentication attempts from other
hosts.

Impact :

A remote attacker can add arbitrary hosts to the block list, denying
legitimate users access to a resource.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200702-05.xml

Solution :

All Fail2ban users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-analyzer/fail2ban-0.6.2'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 24362 (gentoo_GLSA-200702-05.nasl)

Bugtraq ID:

CVE ID: CVE-2006-6302