GLSA-200608-09 : MySQL: Denial of Service

This script is Copyright (C) 2006-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200608-09
(MySQL: Denial of Service)

Jean-David Maillefer discovered a format string vulnerability in where MySQL fails to properly handle specially formatted user
input to the date_format function.

Impact :

By specifying a format string as the first parameter to the date_format
function, an authenticated attacker could cause MySQL to crash,
resulting in a Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All MySQL users should upgrade to the latest version:
# emerge --sync
# emerge --ask --verbose --oneshot '>=dev-db/mysql-4.1.21'

Risk factor :

Medium / CVSS Base Score : 4.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 22167 (gentoo_GLSA-200608-09.nasl)

Bugtraq ID:

CVE ID: CVE-2006-3469