GLSA-200607-01 : mpg123: Heap overflow

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200607-01
(mpg123: Heap overflow)

In httpdget.c, a variable is assigned to the heap, and is supposed to
receive a smaller allocation. As this variable was not terminated
properly, strncpy() will overwrite the data assigned next in memory.

Impact :

By enticing a user to visit a malicious URL, an attacker could possibly
execute arbitrary code with the rights of the user running mpg123.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200607-01.xml

Solution :

All mpg123 users should update to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-sound/mpg123-0.59s-r11'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21908 (gentoo_GLSA-200607-01.nasl)

Bugtraq ID:

CVE ID: CVE-2006-3355