RHEL 3 / 4 : ipsec-tools (RHSA-2006:0267)

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

Updated ipsec-tools packages that fix a bug in racoon are now
available.

This update has been rated as having moderate security impact by the
Red Hat Security Response Team.

The ipsec-tools package is used in conjunction with the IPsec
functionality in the linux kernel and includes racoon, an IKEv1 keying
daemon.

A denial of service flaw was found in the ipsec-tools racoon daemon.
If a victim's machine has racoon configured in a non-recommended
insecure manner, it is possible for a remote attacker to crash the
racoon daemon. (CVE-2005-3732)

Users of ipsec-tools should upgrade to these updated packages, which
contain backported patches, and are not vulnerable to these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2005-3732.html
http://www.nessus.org/u?a4692bd8
http://rhn.redhat.com/errata/RHSA-2006-0267.html

Solution :

Update the affected ipsec-tools package.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 21286 ()

Bugtraq ID:

CVE ID: CVE-2005-3666
CVE-2005-3667
CVE-2005-3668
CVE-2005-3732