GLSA-200604-11 : Crossfire server: Denial of Service and potential arbitrary code execution

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200604-11
(Crossfire server: Denial of Service and potential arbitrary code execution)

Luigi Auriemma discovered a vulnerability in the Crossfire game
server, in the handling of the 'oldsocketmode' option when processing
overly large requests.

Impact :

An attacker can set up a malicious Crossfire client that would
send a large request in 'oldsocketmode', resulting in a Denial of
Service on the Crossfire server and potentially in the execution of
arbitrary code on the server with the rights of the game server.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200604-11.xml

Solution :

All Crossfire server users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=games-server/crossfire-server-1.9.0'

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21276 (gentoo_GLSA-200604-11.nasl)

Bugtraq ID:

CVE ID: CVE-2006-1010