GLSA-200603-04 : IMAP Proxy: Format string vulnerabilities

This script is Copyright (C) 2006-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200603-04
(IMAP Proxy: Format string vulnerabilities)

Steve Kemp discovered two format string errors in IMAP Proxy.

Impact :

A remote attacker could design a malicious IMAP server and entice
someone to connect to it using IMAP Proxy, resulting in the execution
of arbitrary code with the rights of the victim user.

Workaround :

Only connect to trusted IMAP servers using IMAP Proxy.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200603-04.xml

Solution :

All IMAP Proxy users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-mail/up-imapproxy-1.2.4'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 21021 (gentoo_GLSA-200603-04.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2661