Ubuntu 4.10 : imlib+png2 vulnerabilities (USN-53-1)

Ubuntu Security Notice (C) 2004-2013 Canonical, Inc. / NASL script (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Pavel Kankovsky discovered several buffer overflows in imlib. If an
attacker tricked a user into loading a malicious image, he could
exploit this to execute arbitrary code in the context of the user
opening the image.

Solution :

Update the affected packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 20671 ()

Bugtraq ID:

CVE ID: CVE-2004-1025
CVE-2004-1026