Ubuntu 4.10 : imagemagick vulnerabilities (USN-35-1)

Ubuntu Security Notice (C) 2004-2013 Canonical, Inc. / NASL script (C) 2006-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Markus Meissner discovered several potential buffer overflows in some
image decoding functions of ImageMagick. Decoding a malicious BMP or
DIB image or AVI video might result in execution of arbitrary code
with the user's privileges.

Since imagemagick can be used in custom printing systems, this also
might lead to privilege escalation (execute code with the printer
spooler's privileges). However, Ubuntu's standard printing system does
not use imagemagick, thus there is no risk of privilege escalation in
a standard installation.

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 20651 ()

Bugtraq ID:

CVE ID: CVE-2004-0827