GLSA-200510-20 : Zope: File inclusion through RestructuredText

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200510-20
(Zope: File inclusion through RestructuredText)

Zope honors file inclusion directives in RestructuredText objects by
default.

Impact :

An attacker could exploit the vulnerability by sending malicious input
that would be interpreted in a RestructuredText Zope object,
potentially resulting in the execution of arbitrary Zope code with the
rights of the Zope server.

Workaround :

There is no known workaround at this time.

See also :

http://www.zope.org/Products/Zope/Hotfix_2005-10-09/security_alert
http://www.gentoo.org/security/en/glsa/glsa-200510-20.xml

Solution :

All Zope users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose net-zope/zope

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 20102 (gentoo_GLSA-200510-20.nasl)

Bugtraq ID:

CVE ID: CVE-2005-3323