ATutor < 1.5.1-pl1 Multiple Remote Vulnerabilities (XSS, RFI, Command Exe)

This script is Copyright (C) 2005-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server contains a PHP application that is prone to
multiple vulnerabilities.

Description :

The remote host is running ATutor, an open source, web-based Learning
Content Management System (LCMS) written in PHP.

The version of ATutor installed on the remote host may be vulnerable
to arbitrary command execution, arbitrary file access, and cross-site
scripting attacks. Successful exploitation of the first two issues
requires that PHP's 'register_globals' setting be enabled and, in some
cases, that 'magic_quotes_gpc' be disabled.

See also :

Solution :

Apply patch 1.5.1-pl1 or upgrade to version 1.5.2 or later.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.5
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 20095 (atutor_multiple_flaws.nasl)

Bugtraq ID: 15221

CVE ID: CVE-2005-3403