GLSA-200509-03 : OpenTTD: Format string vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200509-03
(OpenTTD: Format string vulnerabilities)

Alexey Dobriyan discovered several format string vulnerabilities in
OpenTTD.

Impact :

A remote attacker could exploit these vulnerabilities to crash the
OpenTTD server or client and possibly execute arbitrary code with the
rights of the user running OpenTTD.

Workaround :

There are no known workarounds at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200509-03.xml

Solution :

All OpenTTD users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=games-simulation/openttd-0.4.0.1-r1'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 19578 (gentoo_GLSA-200509-03.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2763
CVE-2005-2764