GLSA-200507-10 : Ruby: Arbitrary command execution through XML-RPC

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200507-10
(Ruby: Arbitrary command execution through XML-RPC)

Nobuhiro IMAI reported that an invalid default value in 'utils.rb'
causes the security protections of the XML-RPC server to fail.

Impact :

A remote attacker could exploit this vulnerability to execute
arbitrary commands.

Workaround :

There is no known workaround at this time.

See also :

http://www.ruby-lang.org/en/20050701.html
http://www.gentoo.org/security/en/glsa/glsa-200507-10.xml

Solution :

All Ruby users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-lang/ruby-1.8.2-r2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18669 (gentoo_GLSA-200507-10.nasl)

Bugtraq ID:

CVE ID: CVE-2005-1992