GLSA-200506-24 : Heimdal: Buffer overflow vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200506-24
(Heimdal: Buffer overflow vulnerabilities)

It has been reported that the 'getterminaltype' function of
Heimdal's telnetd server is vulnerable to buffer overflows.

Impact :

An attacker could exploit this vulnerability to execute arbitrary
code with the permission of the telnetd server program.

Workaround :

There is no known workaround at this time.

See also :

http://www.pdc.kth.se/heimdal/advisory/2005-06-20/
http://www.gentoo.org/security/en/glsa/glsa-200506-24.xml

Solution :

All users should upgrade to the latest available version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=app-crypt/heimdal-0.6.5'

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18590 (gentoo_GLSA-200506-24.nasl)

Bugtraq ID:

CVE ID: CVE-2005-2040