GLSA-200506-04 : Wordpress: Multiple vulnerabilities

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200506-04
(Wordpress: Multiple vulnerabilities)

Due to a lack of input validation, WordPress is vulnerable to SQL
injection and XSS attacks.

Impact :

An attacker could use the SQL injection vulnerabilities to gain
information from the database. Furthermore the cross-site scripting
issues give an attacker the ability to inject and execute malicious
script code or to steal cookie-based authentication credentials,
potentially compromising the victim's browser.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200506-04.xml

Solution :

All Wordpress users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/wordpress-1.5.1.2'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 18427 (gentoo_GLSA-200506-04.nasl)

Bugtraq ID:

CVE ID: CVE-2005-1102
CVE-2005-1687
CVE-2005-1810