Apache Tomcat < 6.0.13 Multiple Vulnerabilities

This script is Copyright (C) 2011-2015 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat service is potentially affected by multiple

Description :

According to its self-reported version number, the Apache Tomcat
listening on the remote host is earlier than Tomcat 6.0.13 and is
potentially affected by the following vulnerabilities:

- Requests containing multiple 'content-length' headers
are not rejected as invalid. This error can allow
web-cache poisoning, cross-site scripting attacks and
information disclosure. (CVE-2005-2090)

- The remote Apache Tomcat install may be vulnerable to
a cross-site scripting attack if the JSP and Servlet
examples are enabled. Several of these examples do
not properly validate user input. (CVE-2007-1355)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page so this may be
a false positive.

See also :


Solution :

Update Apache Tomcat to version 6.0.13 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.6
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 17728 ()

Bugtraq ID: 13873

CVE ID: CVE-2005-2090