GLSA-200501-45 : Gallery: Cross-site scripting vulnerability

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-45
(Gallery: Cross-site scripting vulnerability)

Rafel Ivgi has discovered a cross-site scripting vulnerability where
the 'username' parameter is not properly sanitized in 'login.php'.

Impact :

By sending a carefully crafted URL, an attacker can inject and execute
script code in the victim's browser window, and potentially compromise
the user's gallery.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?335f9d0c
http://secunia.com/advisories/13887/
http://www.gentoo.org/security/en/glsa/glsa-200501-45.xml

Solution :

All Gallery users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/gallery-1.4.4_p6'
Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16436 (gentoo_GLSA-200501-45.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0220