GLSA-200501-41 : TikiWiki: Arbitrary command execution

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-41
(TikiWiki: Arbitrary command execution)

TikiWiki does not validate files uploaded to the 'temp' directory.

Impact :

A malicious user could run arbitrary commands on the server by
uploading and calling a PHP script.

Workaround :

There is no known workaround at this time.

See also :

http://tikiwiki.org/art102
http://www.gentoo.org/security/en/glsa/glsa-200501-41.xml

Solution :

All TikiWiki users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-apps/tikiwiki-1.8.5'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16432 (gentoo_GLSA-200501-41.nasl)

Bugtraq ID:

CVE ID: CVE-2005-0200