GLSA-200501-19 : imlib2: Buffer overflows in image decoding

This script is Copyright (C) 2005-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200501-19
(imlib2: Buffer overflows in image decoding)

Pavel Kankovsky discovered that several buffer overflows found in
the libXpm library (see GLSA 200409-34) also apply to imlib (see GLSA
200412-03) and imlib2. He also fixed a number of other potential
security vulnerabilities.

Impact :

A remote attacker could entice a user to view a carefully-crafted
image file, which would potentially lead to the execution of arbitrary
code with the rights of the user viewing the image. This affects any
program that utilizes of the imlib2 library.

Workaround :

There is no known workaround at this time.

See also :

http://security.gentoo.org/glsa/glsa-200412-03.xml
http://www.gentoo.org/security/en/glsa/glsa-200501-19.xml

Solution :

All imlib2 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-libs/imlib2-1.2.0'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16410 (gentoo_GLSA-200501-19.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1026