GLSA-200412-23 : Zwiki: XSS vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200412-23
(Zwiki: XSS vulnerability)

Due to improper input validation, Zwiki can be exploited to perform
cross-site scripting attacks.

Impact :

By enticing a user to read a specially-crafted wiki entry, an attacker
can execute arbitrary script code running in the context of the
victim's browser.

Workaround :

There is no known workaround at this time.

See also :

http://zwiki.org/925ZwikiXSSVulnerability
http://www.gentoo.org/security/en/glsa/glsa-200412-23.xml

Solution :

All Zwiki users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-zope/zwiki-0.36.2-r1'

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 16034 (gentoo_GLSA-200412-23.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1075