GLSA-200412-09 : ncpfs: Buffer overflow in ncplogin and ncpmap

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200412-09
(ncpfs: Buffer overflow in ncplogin and ncpmap)

Karol Wiesek discovered a buffer overflow in the handling of the
'-T' option in the ncplogin and ncpmap utilities, which are both
installed as SUID root by default.

Impact :

A local attacker could trigger the buffer overflow by calling one
of these utilities with a carefully crafted command line, potentially
resulting in execution of arbitrary code with root privileges.

Workaround :

There is no known workaround at this time.

See also :

http://www.nessus.org/u?45c10881
http://www.gentoo.org/security/en/glsa/glsa-200412-09.xml

Solution :

All ncpfs users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-fs/ncpfs-2.2.5'

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15969 (gentoo_GLSA-200412-09.nasl)

Bugtraq ID:

CVE ID: CVE-2004-1079