GLSA-200411-11 : ImageMagick: EXIF buffer overflow

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200411-11
(ImageMagick: EXIF buffer overflow)

ImageMagick fails to do proper bounds checking when handling image files
with EXIF information.

Impact :

An attacker could use an image file with specially crafted EXIF information
to cause arbitrary code execution with the permissions of the user running

Workaround :

There is no known workaround at this time.

See also :

Solution :

All ImageMagick users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-gfx/imagemagick-'

Risk factor :

Critical / CVSS Base Score : 10.0

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15645 (gentoo_GLSA-200411-11.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0981