GLSA-200411-03 : Apache 1.3: Buffer overflow vulnerability in mod_include

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200411-03
(Apache 1.3: Buffer overflow vulnerability in mod_include)

A possible buffer overflow exists in the get_tag() function of

Impact :

If Server Side Includes (SSI) are enabled, a local attacker may be able to
run arbitrary code with the rights of an httpd child process by making use
of a specially crafted document with malformed SSI.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Apache users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-servers/apache-1.3.32-r1'

Risk factor :

Medium / CVSS Base Score : 6.9

Family: Gentoo Local Security Checks

Nessus Plugin ID: 15606 (gentoo_GLSA-200411-03.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0940