GLSA-200409-20 : mpg123: Buffer overflow vulnerability

This script is Copyright (C) 2004-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-200409-20
(mpg123: Buffer overflow vulnerability)

mpg123 contains a buffer overflow in the code that handles layer2
decoding of media files.

Impact :

An attacker can possibly exploit this bug with a specially crafted mp3 or mp2 file
to execute arbitrary code with the permissions of the user running mpg123.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All mpg123 users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=media-sound/mpg123-0.59s-r4'
# emerge '>=media-sound/mpg123-0.59s-r4'

Risk factor :

High / CVSS Base Score : 7.5

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14747 (gentoo_GLSA-200409-20.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0805