GLSA-200407-18 : mod_ssl: Format string vulnerability

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200407-18
(mod_ssl: Format string vulnerability)

A bug in ssl_engine_ext.c makes mod_ssl vulnerable to a ssl_log() related
format string vulnerability in the mod_proxy hook functions.

Impact :

Given the right server configuration, an attacker could execute code as the
user running Apache, usually 'apache'.

Workaround :

A server should not be vulnerable if it is not using both mod_ssl and
mod_proxy. Otherwise there is no workaround other than to disable mod_ssl.

See also :

http://marc.info/?l=apache-modssl&m=109001100906749&w=2
http://www.gentoo.org/security/en/glsa/glsa-200407-18.xml

Solution :

All mod_ssl users should upgrade to the latest version:
# emerge sync
# emerge -pv '>=net-www/mod_ssl-2.8.19'
# emerge '>=net-www/mod_ssl-2.8.19'

Risk factor :

Medium

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14551 (gentoo_GLSA-200407-18.nasl)

Bugtraq ID:

CVE ID: