GLSA-200407-06 : libpng: Buffer overflow on row buffers

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200407-06
(libpng: Buffer overflow on row buffers)

Due to a wrong calculation of loop offset values, libpng contains a buffer
overflow vulnerability on the row buffers. This vulnerability was initially
patched in January 2003 but since it has been discovered that libpng
contains the same vulnerability in two other places.

Impact :

An attacker could exploit this vulnerability to cause programs linked
against the library to crash or execute arbitrary code with the permissions
of the user running the vulnerable program, which could be the root user.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200407-06.xml

Solution :

All libpng users should upgrade to the latest stable version:
# emerge sync
# emerge -pv '>=media-libs/libpng-1.2.5-r7'
# emerge '>=media-libs/libpng-1.2.5-r7'
You should also run revdep-rebuild to rebuild any packages that depend on
older versions of libpng :
# revdep-rebuild

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14539 (gentoo_GLSA-200407-06.nasl)

Bugtraq ID:

CVE ID: CVE-2002-1363