GLSA-200406-14 : aspell: Buffer overflow in word-list-compress

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200406-14
(aspell: Buffer overflow in word-list-compress)

aspell includes a utility for handling wordlists called
word-list-compress. This utility fails to do proper bounds checking
when processing words longer than 256 bytes.

Impact :

If an attacker could entice a user to handle a wordlist containing very
long word lengths it could result in the execution of arbitrary code
with the permissions of the user running the program.

Workaround :

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version.

See also :

http://archives.neohapsis.com/archives/secunia/2004-q2/0616.html
http://www.gentoo.org/security/en/glsa/glsa-200406-14.xml

Solution :

All users should upgrade to the latest available version of aspell.
# emerge sync
# emerge -pv '>=app-text/aspell-0.50.5-r4'
# emerge '>=app-text/aspell-0.50.5-r4'

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14525 (gentoo_GLSA-200406-14.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0548