GLSA-200405-04 : OpenOffice.org vulnerability when using DAV servers

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200405-04
(OpenOffice.org vulnerability when using DAV servers)

OpenOffice.org includes code from the Neon library in functions related to
publication on WebDAV servers. This library is vulnerable to several format
string attacks.

Impact :

If you use the WebDAV publication and connect to a malicious WebDAV server,
this server can exploit these vulnerabilities to execute arbitrary code
with the rights of the user running OpenOffice.org.

Workaround :

As a workaround, you should not use the WebDAV publication facilities.

See also :

http://www.gentoo.org/security/en/glsa/glsa-200405-01.xml
http://www.gentoo.org/security/en/glsa/glsa-200405-04.xml

Solution :

There is no Ximian OpenOffice.org binary version including the fix yet. All
users of the openoffice-ximian-bin package making use of the WebDAV
openoffice-ximian source-based package.
openoffice users on the x86 architecture should:
# emerge sync
# emerge -pv '>=app-office/openoffice-1.1.1-r1'
# emerge '>=app-office/openoffice-1.1.1-r1'
openoffice users on the sparc architecture should:
# emerge sync
# emerge -pv '>=app-office/openoffice-1.1.0-r3'
# emerge '>=app-office/openoffice-1.1.0-r3'
openoffice users on the ppc architecture should:
# emerge sync
# emerge -pv '>=app-office/openoffice-1.0.3-r1'
# emerge '>=app-office/openoffice-1.0.3-r1'
openoffice-ximian users should:
# emerge sync
# emerge -pv '>=app-office/openoffice-ximian-1.1.51-r1'
# emerge '>=app-office/openoffice-ximian-1.1.51-r1'
openoffice-bin users should:
# emerge sync
# emerge -pv '>=app-office/openoffice-bin-1.1.2'
# emerge '>=app-office/openoffice-bin-1.1.2'

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14490 (gentoo_GLSA-200405-04.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0179