GLSA-200403-13 : Remote buffer overflow in MPlayer

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-200403-13
(Remote buffer overflow in MPlayer)

A vulnerability exists in the MPlayer HTTP parser which may allow an
attacker to craft a special HTTP header ('Location:') which will trick
MPlayer into executing arbitrary code on the user's computer.

Impact :

An attacker without privileges may exploit this vulnerability remotely,
allowing arbitrary code to be executed in order to gain unauthorized
access.

Workaround :

A workaround is not currently known for this issue. All users are
advised to upgrade to the latest version of the affected package.

See also :

http://mplayerhq.hu
http://www.mplayerhq.hu/homepage/design6/news.html
http://www.gentoo.org/security/en/glsa/glsa-200403-13.xml

Solution :

MPlayer may be upgraded as follows:
x86 and SPARC users should:
# emerge sync
# emerge -pv '>=media-video/mplayer-0.92-r1'
# emerge '>=media-video/mplayer-0.92-r1'
AMD64 users should:
# emerge sync
# emerge -pv '>=media-video/mplayer-1.0_pre2-r1'
# emerge '>=media-video/mplayer-1.0_pre2-r1'
PPC users should:
# emerge sync
# emerge -pv '>=media-video/mplayer-1.0_pre3-r2'
# emerge '>=media-video/mplayer-1.0_pre3-r2'

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 14464 (gentoo_GLSA-200403-13.nasl)

Bugtraq ID:

CVE ID: CVE-2004-0386