4D WebStar Arbitrary Multiple Vulnerabilities

This script is Copyright (C) 2004-2011 Tenable Network Security, Inc.


Synopsis :

The remote web server is susceptible to multiple attacks.

Description :

The remote server is running a version of 4D WebStar Web Server
earlier than 5.3.3. Such versions are reportedly affected by
multiple issues :

- An attacker may be able to obtain the listing of a
directory by appending a star (*) to the directory name.

- An attacker may obtain the file php.ini by requesting
/cgi-bin/php.ini.

See also :

http://archives.neohapsis.com/archives/vulnwatch/2004-q3/0005.html

Solution :

Upgrade to 4D WebStar 5.3.3 or newer.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.3
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 14196 (4d_webstar_information_disclosure.nasl)

Bugtraq ID: 10721

CVE ID: CVE-2004-0696