l2tpd < 0.69 control.c write_packet Function Remote Overflow

This script is Copyright (C) 2004-2011 Tenable Network Security, Inc.


Synopsis :

The remote host is running a network tunneling application that is
affected by a buffer overflow vulnerability.

Description :

The remote host is running a version of l2tpd which is older or
equal to 0.68.

This version is vulnerable to a buffer overflow which might allow an
attacker to execute arbitrary commands on the remote host with
super-user privileges.

See also :

http://seclists.org/lists/bugtraq/2004/Jun/0073.html

Solution :

Upgrade to l2tpd 0.69 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:ND)
Public Exploit Available : false

Family: Gain a shell remotely

Nessus Plugin ID: 13659 (l2tpd_overflow2.nasl)

Bugtraq ID: 10466

CVE ID: CVE-2004-0649