RHEL 2.1 / 3 : lha (RHSA-2004:178)

This script is Copyright (C) 2004-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing a security update.

Description :

An updated LHA package that fixes several security vulnerabilities is
now available.

LHA is an archiving and compression utility for LHarc format archives.

Ulf Harnhammar discovered two stack-based buffer overflows and two
directory traversal flaws in LHA. An attacker could exploit the buffer
overflows by creating a carefully crafted LHA archive in such a way
that arbitrary code would be executed when the archive is tested or
extracted by a victim. The Common Vulnerabilities and Exposures
project (cve.mitre.org) has assigned the name CVE-2004-0234 to this
issue. An attacker could exploit the directory traversal issues to
create files as the victim outside of the expected directory. The
Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CVE-2004-0235 to this issue.

Users of LHA should update to this updated package which contains
backported patches not vulnerable to these issues.

Red Hat would like to thank Ulf Harnhammar for disclosing and
providing test cases and patches for these issues.

See also :

https://www.redhat.com/security/data/cve/CVE-2004-0234.html
https://www.redhat.com/security/data/cve/CVE-2004-0235.html
http://rhn.redhat.com/errata/RHSA-2004-178.html

Solution :

Update the affected lha package.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 12491 ()

Bugtraq ID:

CVE ID: CVE-2004-0234
CVE-2004-0235