OpenSSH < 3.7.1 Multiple Vulnerabilities

This script is Copyright (C) 2003-2014 Tenable Network Security, Inc.


Synopsis :

The remote SSH service is affected by various memory bugs.

Description :

According to its banner, the remote SSH server is running a version of
OpenSSH older than 3.7.1. Such versions are vulnerable to a flaw in
the buffer management functions that might allow an attacker to
execute arbitrary commands on this host.

An exploit for this issue is rumored to exist.

Note that several distributions patched this hole without changing the
version number of OpenSSH. Since Nessus solely relied on the banner
of the remote SSH server to perform this check, this might be a false
positive.

If you are running a RedHat host, make sure that the command :

rpm -q openssh-server

returns :

openssh-server-3.1p1-13 (RedHat 7.x)
openssh-server-3.4p1-7 (RedHat 8.0)
openssh-server-3.5p1-11 (RedHat 9)

See also :

http://marc.info/?l=openbsd-misc&m=106375452423794&w=2
http://marc.info/?l=openbsd-misc&m=106375456923804&w=2

Solution :

Upgrade to OpenSSH 3.7.1 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gain a shell remotely

Nessus Plugin ID: 11837 ()

Bugtraq ID: 8628

CVE ID: CVE-2003-0682
CVE-2003-0693
CVE-2003-0695
CVE-2004-2760