Abyss Web Server GET Request Multiple Vulnerabilities

This script is Copyright (C) 2003-2011 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

The remote Abyss Web server is earlier than version 1.1.6. Such
versions are reportedly vulnerable to a buffer overflow that could be
exploited by an attacker to execute arbitrary code on the host.

In addition, it is possible to inject malicious data into server
response headers using a specially crafted GET request. An attacker
could use this vulnerability to launch cross-site scripting

See also :


Solution :

Upgrading to Abyss 1.1.6 or newer is reported to fix the problem.

Risk factor :

High / CVSS Base Score : 7.5
CVSS Temporal Score : 7.1
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 11784 (abyss_overflow.nasl)

Bugtraq ID: 8062

CVE ID: CVE-2003-1337